2017 Front Spoiler

Randwulf

New member
Messages
6
Reactions
0
#1
Hello, all. I have a 2017 Alltrack S that I bought new almost two years ago. I have a little over 25,000 miles on it. Here's my problem. Apparently, I got too close to a curb guard and pulled the front spoiler loose. I don't know when I did it; I just noticed it hanging down from the driver's side when I came out of the gas station last week. I had to look this part up because I did not know what it was called--seems weird calling this little cheap piece of plastic under the front end a spoiler. Anyway, I snapped it back into place but it came loose again on a road trip. Every time a larger vehicle would pass me in the opposite lane, the air turbulence from that vehicle would cause the spoiler to catch air and vibrate like the front end was coming out of the car. I never thought a piece of plastic could cause such a rumbling, clattering noise. I can't drive the car until I resolve this issue.

I am going to try to put a couple of screws in to hold it up. Has anyone else had this problem? What was your fix?

Thanks for reading.
 
Messages
95
Reactions
2
#2
Hello, all. I have a 2017 Alltrack S that I bought new almost two years ago. I have a little over 25,000 miles on it. Here's my problem. Apparently, I got too close to a curb guard and pulled the front spoiler loose. I don't know when I did it; I just noticed it hanging down from the driver's side when I came out of the gas station last week. I had to look this part up because I did not know what it was called--seems weird calling this little cheap piece of plastic under the front end a spoiler. Anyway, I snapped it back into place but it came loose again on a road trip. Every time a larger vehicle would pass me in the opposite lane, the air turbulence from that vehicle would cause the spoiler to catch air and vibrate like the front end was coming out of the car. I never thought a piece of plastic could cause such a rumbling, clattering noise. I can't drive the car until I resolve this issue.

I am going to try to put a couple of screws in to hold it up. Has anyone else had this problem? What was your fix?

Thanks for reading.
If you could post a picture that might help with the suggestions. Me? I'd like to know how to post pics here I've posted that question not one reply.
Getting back to your issue, (just guessing) but you've probably broke some or all the tabs that hold the spoiler on. Screws with a backing 'clip' (pretty common piece at Lowes or Home Depot) should do the trick to get you back on the road. I've noticed there isn't much action on this site and that's a shame. When I first came here I thought perfect I don't have to go to VWVortex and filter thru a bunch of childish comments. I wish this site was more active. I hope my answer helped. EDIT: just noticed the date you posted you've probably got it fixed by now.
 


Top