LED conversion for rear hatch/cargo area

Messages
22
Reactions
0
#1
All the interior illumination in my S is LED except the rear. The dim, yellow incandescent is out of place. So I replaced with an LED bulb. But when it is turned off, still dimly lid.
Not enough load or current draw I guess for the circuit to fully open, possibly solid state switching. Are the SE and SEL the same? Or do they have an LED module? Anyone know of a festoon LED that won't do this? Do the Can Bus bulbs correct this issue?
 
Messages
14
Reactions
0
#3
I did change mine too of my 2017 Alltrack SE.. it’s slightly lit but after a few minute when you turn off engine it’s totally off.. so far it didn’t give my any troubles yet ... I bought the LED bulb at Walmart last year ..


Sent from my iPhone using Tapatalk
 

AlltrackMike

Active member
Messages
548
Reactions
0
#4
Are they much brighter than stock?
 
Messages
14
Reactions
0
#5
Yes.. not blinding bright but you can tell the difference and see much better.. doesn’t flicker which is good...


Sent from my iPhone using Tapatalk
 
Messages
83
Reactions
0
#6
I kind of wish they came with LED from the factory.
 
Messages
14
Reactions
0
#7
All the interior illumination in my S is LED except the rear. The dim, yellow incandescent is out of place. So I replaced with an LED bulb. But when it is turned off, still dimly lid.
Not enough load or current draw I guess for the circuit to fully open, possibly solid state switching. Are the SE and SEL the same? Or do they have an LED module? Anyone know of a festoon LED that won't do this? Do the Can Bus bulbs correct this issue?



Sent from my iPhone using Tapatalk
 
Messages
14
Reactions
0
#8
All the interior illumination in my S is LED except the rear. The dim, yellow incandescent is out of place. So I replaced with an LED bulb. But when it is turned off, still dimly lid.
Not enough load or current draw I guess for the circuit to fully open, possibly solid state switching. Are the SE and SEL the same? Or do they have an LED module? Anyone know of a festoon LED that won't do this? Do the Can Bus bulbs correct this issue?
I have a 2017 Alltrack SE the boot has incandescent bulb so I bought an LED replacement , when I just turned off the car it’s dimly lit but when the car is totally off/ parked , LED is completely off... so far it didn’t cause any trouble ... it’s been over a year since I installed it ...


Sent from my iPhone using Tapatalk
 

Similar threads



Top